Kurs XMEGA (18): SPI w XMEGA

|

Strona przeniesiona na nowy adres:
extronic.pl


7 komentarze :

Anonimowy pisze...

ten kod się nie kompiluje
Error 'PORT_t' has no member named 'REMAP' .
Error 'PORT_SPI_bm' undeclared (first use in this function)
Message each undeclared identifier is reported only once for each function it appears in

Dominik Leon Bieczyński pisze...

a na jakim procesorze to próbujesz skompilować?

Anonimowy pisze...

Na Waszej płytce X3-DIL64

Dominik Leon Bieczyński pisze...

Na naszej płytce X3-DIL64 ten kod się kompiluje. Błąd jest spowodowany tym, że próbujesz skompilować ten kod na procesor, który nie obsługuje remapowania pinów. Jednak procesor ATxmega128A3U na płytce X3-DIL64 oraz eXtrino XL remapowanie obsługuje i ten kod na 100% działa ;) jest wykorzystywany w dalszych odcinkach.

Anonimowy pisze...

Witam, mam prośbę, czy mógłby mi ktoś pomóc w uruchomieniu SPI?
Testuję czujnik ciśnienia MS5611 i na płytce X-DIL64 wszystko działa bez problemu. Ale gdy próbuję kod przenieść na docelowy procek xmega32E5 to coś nawala komunikacja z czujnikiem przez SPI. Podpięcie czunika do pinów pozostawiam takie samo, zegar taktowany tak samo. Czy SPI w prockach serii E5 jakoś inaczej się konfiguruje ?
Jako że tutaj nie da się zamieszczać obrazków - całość tematu jest tu. http://www.elektroda.pl/rtvforum/viewtopic.php?t=3142639&highlight=

Rafal Drzewiecki pisze...

Czy SPI w xmega wykonuje 15 czy 16 cykli SCK? Czy to się konfiguruje mam problem z obsługą ekranu dotykowego który jest sterowany po SPI. Tradycyjną metodą czyli ustaw pin na 0 potem na 1 itd działa ale z przedstawionym przykładem wykorzystującym SPI które oferuje xmega już nie chce. Tak jakby brakowała jednego cyklu. Układ XPT2046.

andycrofts pisze...

Nice if I didn't have to use Google Translate! My Finnish is a bit rusty..;)

(Joke - I live in Finland. And it's still rusty...)

Prześlij komentarz

Skomentuj!

Sklep Leon Instruments